Delay in USDT fulfilment
Incident Report for Banxa Status Updates
Resolved
This incident has been resolved.
Posted Jul 24, 2021 - 20:59 AEST
Investigating
We are currently experiencing delay in fulfilling USDT due to issue from our upstream provider. We are working to resolve the issue as soon as possible.
Posted Jul 24, 2021 - 16:45 AEST
This incident affected: Digital Currency Fulfillment (Tether (USDT)).