USDT fulfilment on small orders
Incident Report for Banxa Status Updates
Resolved
This incident has been resolved.
Posted Dec 21, 2021 - 10:52 AEDT
Investigating
We are having fulfilment issue from our upstream providers for orders less than or equal 50USDT.

We have temporary increased the minimum limit of our USDT orders to be 50USDT for now to avoid the delay in fulfilment for users. We are working hard with different stakeholders to resolve the issue.
Posted Dec 20, 2021 - 15:37 AEDT
This incident affected: Digital Currency Fulfillment (Tether (USDT)).