Intermittent delay in fulfillment
Incident Report for Banxa Status Updates
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 16:33 AEST
Update
The incident has been resolved
Posted Jun 15, 2021 - 16:32 AEST
Investigating
We are having some intermittent delays in fulfilment for these coins: BTC, LINK, XRP, ETH, USDC, BUSD. We are investigating the root of the cause and working on a solution to have orders fulfilled as soon as possible.
Posted Jun 15, 2021 - 10:07 AEST
This incident affected: Digital Currency Fulfillment (Binance USD (BUSD), Bitcoin (BTC), ChainLink (LINK), Ethereum (ETH), USD Coin (USDC)).