Resolved
The issue affecting access to banxa.com has been fully resolved. The third-party service disruption has been cleared, and the site is now accessible. All services are operating normally.
Monitoring
Hi,
We are currently experiencing an issue where banxa.com is inaccessible. This appears to be caused by a third-party service disruption.
Our team is actively monitoring and coordinating with the provider to restore access as soon as possible.